Skip to main content
VulnerabilityPublished

CVE-2026-8106: GitHub Enterprise Server · Cross-site Scripting

Affects GitHub Enterprise ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.9 Medium : upgrade to 3.20.2 or 3.19.6 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.20.2, 3.19.6
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade GitHub Enterprise Server to 3.20.2 or 3.19.6.

Affected software

ProductAffectedFixed in
GitHubEnterprise ServerAffected
  • >=3.20.0 <3.20.2
Fixed in
  • 3.20.2
GitHubEnterprise ServerAffected
  • >=3.19.1 <3.19.6
Fixed in
  • 3.19.6

AI-suggested

This vulnerability has been fixed in GitHub Enterprise Server versions 3.19.6 and 3.20.2. Users should upgrade affected instances to these or later versions to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2026-8106 is a reflected cross-site scripting (XSS) vulnerability in the GitHub Enterprise Server Management Console login page. The issue arises from improper sanitization of the redirect_to query parameter on the /setup/unlock endpoint, allowing injection of malicious HTML elements. An attacker could exploit this by tricking an administrator into clicking a crafted link and entering credentials, potentially leading to credential theft. This vulnerability affects GitHub Enterprise Server versions 3.19.1 through 3.19.5 and 3.20.0 through 3.

References

Community reviews

Loading reviews…