CVE-2026-81340: MasterStudy LMS WordPress Plugin · Insecure Direct Object Reference
Affects MasterStudy LMS WordPress PluginSource CVE Database V5
Not known to be exploited · CVSS 3.8 Low : upgrade to 3.7.50 when convenient.
Data as of 2 Nov 2026, 22:58 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.7.50
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 18 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade MasterStudy LMS WordPress Plugin to 3.7.50.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MasterStudy LMS WordPress Plugin | Affected
| Fixed in
|
AI-suggested
Patch to version 3.7.50 or later where this vulnerability is fixed. Until patched, restrict the Instructor role permissions or disable the REST API endpoints related to order updates if feasible.
Description
The MasterStudy LMS WordPress Plugin WordPress plugin before 3.7.50 does not perform per-object ownership or capability checks when updating orders through its REST API, allowing users with the Instructor role to modify any order on the site, granting free course enrolment, revoking other users' paid enrolments, and tampering with order notes.