Skip to main content
VulnerabilityPublished

CVE-2026-81431: Registration Form for WooCommerce (WordPress plugin) · Improper Privilege Management

Affects Registration Form for WooCommerce (WordPress plugin)Source CVE Database V5

0

Mentioned vulnerabilities

Not known to be exploited · CVSS 7.2 High : upgrade to 1.1.3 soon.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2026-09-10.

Patch
Available – fixed in 1.1.3
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Registration Form for WooCommerce (WordPress plugin) to 1.1.3.

Affected software

ProductAffectedFixed in
Registration Form for WooCommerceAffected
  • >=1.1.0 <1.1.3
Fixed in
  • 1.1.3

AI-suggested

Upgrade the Registration Form for WooCommerce plugin to version 1.1.3 or later, where this vulnerability has been fixed. No additional mitigation is required once the plugin is updated.

Description

The Registration Form for WooCommerce WordPress plugin versions 1.1.0 through 1.1.2 contains an improper privilege management vulnerability. It fails to validate that the form used during registration is legitimate, allowing users with Contributor or higher privileges to manipulate the permitted-role allow-list via attacker-controlled posts. This enables them to register new accounts with arbitrary roles, including Administrator, potentially leading to full site takeover. The issue is a partial fix of a previous vulnerability (CVE-2026-54807) and was resolved in version 1.1.3.

References

Community reviews

Loading reviews…