CVE-2026-8178: Amazon Redshift JDBC Driver · Unsafe Reflection
Affects Amazon Redshift JDBC DriverSource CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 2.2.2 soon.
Data as of 26 Oct 2026, 14:18 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.2.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 8 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Amazon Redshift JDBC Driver and com.amazon.redshift/redshift-jdbc42 to 2.2.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AmazonAmazon Redshift JDBC Driver | Affected
| Fixed in
|
Mavencom.amazon.redshift/redshift-jdbc42pkg:maven/com.amazon.redshift/redshift-jdbc42Other threats | Affected
| Fixed in
|
GitHubAmazon Redshift JDBC Driverpkg:github/Amazon Redshift JDBC DriverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade the Amazon Redshift JDBC Driver to version 2.2.2 or later to remediate this vulnerability. No other mitigations are indicated by the vendor advisory.
Description
Amazon Redshift JDBC Driver versions prior to 2.2.2 contain a vulnerability where externally controlled input in JDBC connection URL parameters can lead to arbitrary class loading and code execution. This occurs if an attacker can influence the connection URL and a suitable class is present on the application's classpath. The vulnerability is addressed by upgrading to version 2.2.2 or later.