Skip to main content
VulnerabilityPublished

CVE-2026-82429: Apache Storm Worker Launcher · Time-of-check Time-of-use (TOCTOU) Race Condition

Affects Apache Storm Worker LauncherSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.8 High : upgrade to 3.1.0 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.1.0
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Apache to 3.1.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Storm Worker LauncherAffected
  • >=3.0.0 <3.1.0
Fixed in
  • 3.1.0
MavenApache Software Foundation/org.apache.storm:storm-corepkg:maven/Apache Software Foundation/org.apache.storm:storm-coreOther threatsAffected
  • >=3.0.0 <3.1.0
Fixed in
  • 3.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache Storm to version 3.1.0 or later, where the vulnerability is fixed by using file descriptors for privileged operations instead of pathnames. After upgrading, rebuild and reinstall the worker-launcher binary; replacing Java artifacts alone is insufficient. Until an upgrade is possible, do not run untrusted topology code on supervisors configured with supervisor.run.worker.as.user, as the launcher is the boundary being crossed.

Description

Description The setuid-root `worker-launcher` binary adjusts ownership and permissions of worker directories by walking the tree with FTS and calling `lchown` and `chmod` on each entry's full pathname while running with an effective uid of 0. Both syscalls re-resolve the path at the time of the call, after FTS has classified the entry, and the trees being walked are owned and writable by the untrusted topology user. A tenant running code on a supervisor node could therefore replace an intermediate directory component with a symbolic link between classification and the privileged operation, redirecting the root-owned `lchown` or `chmod` at an arbitrary file on the host. The operation is repeatable at will, since crashing a worker forces a relaunch and blob updates re-run the walk, so a failed attempt costs the attacker nothing. This crosses the boundary that `supervisor.run.worker.as.user` and container isolation are intended to enforce. It is the same defect class as the Hadoop container-executor issues from which this code derives. Mitigation Upgrade to 3.1.0, where the privileged walk operates on file descriptors it has already stat'd rather than on pathnames re-resolved at call time. Users who cannot upgrade immediately should not run untrusted topology code on supervisors configured with `supervisor.run.worker.as.user`, since the launcher is the boundary being crossed. Note that the launcher must be rebuilt and reinstalled after upgrading; replacing the Java artifacts alone is not sufficient. Credit The ASF -- found using Claude agents to study the security of open-source projects, validated and reported by Apache Storm.

References

Community reviews

Loading reviews…