Skip to main content
VulnerabilityPublished

CVE-2026-82847: Masteriyo LMS (WordPress plugin) · Cross-Site Scripting (XSS)

Affects Masteriyo LMS (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 6.8 Medium : upgrade to 3.4.1 when convenient.

Data as of 28 Oct 2026, 05:12 UTC

CVSS 3.1 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.4.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Masteriyo LMS (WordPress plugin) to 3.4.1.

Affected software

ProductAffectedFixed in
Masteriyo LMSAffected
  • <3.4.1
Fixed in
  • 3.4.1

AI-suggested

Upgrade the Masteriyo LMS plugin to version 3.4.1 or later, where this vulnerability is fixed. There is no indication that any temporary or alternative mitigations exist, so applying the official update is required to remediate the issue.

Description

The Masteriyo LMS WordPress plugin before 3.4.1 does not sanitise and escape one of its course fields before outputting it back in the course editor, allowing users with the instructor role to perform Stored Cross-Site Scripting attacks against higher privileged users such as administrators.

References

Community reviews

Loading reviews…