Skip to main content
VulnerabilityPublished Updated

CVE-2026-8368: OALDERS LWP::UserAgent · Insufficiently Protected Credentials

Affects OALDERS LWP::UserAgentSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 6.83 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.83
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade LWP::UserAgent and libwww-perl to 6.83.

Affected software

ProductAffectedFixed in
OALDERSLWP::UserAgentAffected
  • <6.83
Fixed in
  • 6.83
GitHublibwww-perlpkg:github/libwww-perlOther threatsAffected
  • <6.83
Fixed in
  • 6.83

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should avoid following redirects to untrusted or attacker-controlled hosts when using vulnerable versions of LWP::UserAgent. Consider implementing manual redirect handling that strips sensitive headers or upgrading to a version confirmed to have addressed this issue once available.

Description

CVE-2026-8368 is a vulnerability in OALDERS LWP::UserAgent versions before 6.83 for Perl where Authorization and Proxy-Authorization headers are leaked during cross-origin redirects. The redirect handler fails to strip these sensitive headers on 3xx responses, sending them unchanged to the redirect target, which can be an attacker-controlled host. This results in disclosure of the caller's credentials. The vulnerability has a medium severity with a CVSS score of 6.5.

References

Community reviews

Loading reviews…