CVE-2026-84088: Xpro Addons (WordPress plugin) · Cross-Site Scripting (XSS)
Affects Xpro Addons (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.8 Medium : upgrade to 1.7.9 when convenient.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.7.9
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade Xpro Addons (WordPress plugin) to 1.7.9.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Xpro Addons — 140+ Widgets for Elementor | Affected
| Fixed in
|
AI-suggested
Upgrade the Xpro Addons — 140+ Widgets for Elementor plugin to version 1.7.9 or later, where this vulnerability is fixed. No other mitigation guidance is provided. Patch status is not explicitly confirmed in the input data, but the presence of a fixed version (1.7.9) indicates an official fix is available.
Description
CVE-2026-84088 is a cross-site scripting (XSS) vulnerability in the Xpro Addons — 140+ Widgets for Elementor WordPress plugin versions before 1.7.9. The flaw allows users with contributor role or higher to inject and store malicious JavaScript via a widget link setting, which executes in the browsers of users interacting with the affected widget.