Skip to main content
VulnerabilityPublished

CVE-2026-84740: The Events Calendar (WordPress plugin) · Injection

Affects The Events Calendar (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 6.17.5.1 when convenient.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers can reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-10-02.

Patch
Available – fixed in 6.17.5.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade The Events Calendar (WordPress plugin) to 6.17.5.1.

Affected software

ProductAffectedFixed in
The Events CalendarAffected
  • >=6.12.0 <6.17.5.1
Fixed in
  • 6.17.5.1

AI-suggested

Upgrade The Events Calendar plugin to version 6.17.5.1 or later, where this vulnerability is fixed. No other mitigation is required as the fix addresses the root cause.

Description

The Events Calendar WordPress plugin versions from 6.12.0 up to but not including 6.17.5.1 contain a vulnerability where unauthenticated users can submit data to an AJAX action that is not properly validated or sanitized. This flaw allows execution of arbitrary shortcodes registered on the site, potentially leading to limited confidentiality and integrity impacts. The issue is fixed in version 6.17.5.1.

References

Community reviews

Loading reviews…