CVE-2026-84829: Optimole (WordPress plugin) · Cross-Site Scripting (XSS)
Affects Optimole (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 4.2.12 soon.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.2.12
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade Optimole (WordPress plugin) to 4.2.12.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Optimole | Affected
| Fixed in
|
AI-suggested
A fix is available in Optimole version 4.2.12. Users should upgrade to version 4.2.12 or later to remediate this vulnerability. No other mitigation or temporary workaround is indicated.
Description
CVE-2026-84829 is a stored Cross-Site Scripting (XSS) vulnerability in the Optimole WordPress plugin versions 4.2.3 up to but not including 4.2.12. The flaw arises because the plugin does not properly escape user-supplied input before using it in an image tag attribute. This allows unauthenticated attackers to inject arbitrary attributes into pages served to all visitors, potentially leading to full compromise of confidentiality, integrity, and availability.