Skip to main content
VulnerabilityPublished

CVE-2026-84915: Drupal Component blocks · Cross-site Scripting

Affects Drupal Component blocksSource CVE Database V5

0

Not known to be exploited · CVSS 4.6 Medium : upgrade to 1.2.7 when convenient.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
4.6Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.2.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Drupal Component blocks to 1.2.7.

Affected software

ProductAffectedFixed in
DrupalComponent blocksAffected
  • <1.2.7
Fixed in
  • 1.2.7

AI-suggested

If you cannot patch yet, consider restricting input sources or applying manual input sanitization if feasible.

Description

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Component blocks allows Stored XSS. This issue affects Component blocks versions: from 0.0.0 to 1.2.7.

References

Community reviews

Loading reviews…