Skip to main content
VulnerabilityPublished

CVE-2026-85228: AWS Deep Java Library · Integer Overflow or Wraparound

Affects AWS Deep Java LibrarySource CVE Database V5

0

Not known to be exploited · CVSS 9.1 Critical · fixed in 0.37.0 : patch AWS Deep Java Library as a priority.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers can reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-09-10.

Patch
Available – fixed in 0.37.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
AmazonDeep Java LibraryAffected
  • >=0.13.0 <=0.36.0
Fixed in–

AI-suggested

Users should upgrade Amazon Deep Java Library to version 0.37.0 or later, where this vulnerability is fixed. No other mitigation or workaround is indicated by the vendor advisory.

Description

CVE-2026-85228 is a critical integer overflow vulnerability in the tensor buffer validation component of Amazon Deep Java Library (DJL) versions 0.13.0 through 0.36.0. This flaw could allow a remote unauthenticated attacker to read adjacent process memory or cause a denial of service by sending a specially crafted tensor payload. The issue is fixed in version 0.37.0 and later.

Reports on CVE-2026-85228

References

Community reviews

Loading reviews…