Skip to main content
VulnerabilityPublished

CVE-2026-85297: Google Cloud Cloud Run MCP · Generation of Predictable Numbers or Identifiers

Affects Google Cloud Cloud Run MCPSource CVE Database V5

0

Not known to be exploited · CVSS 7.7 High : upgrade to 1.11.0 soon.

Data as of 26 Oct 2026, 16:53 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.11.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L/U:Amber

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Cloud Run MCP and googlecloudplatform/cloud-run-mcp to 1.11.0.

Affected software

ProductAffectedFixed in
Google CloudCloud Run MCPAffected
  • <1.11.0
Fixed in
  • 1.11.0
GitHubgooglecloudplatform/cloud-run-mcppkg:github/googlecloudplatform/cloud-run-mcpOther threatsAffected
  • <1.11.0
Fixed in
  • 1.11.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users must upgrade Google Cloud Run MCP to version 1.11.0 or later to remediate this vulnerability. Since this is a cloud service, Google manages remediation for the cloud-hosted service, but customers should verify that their environments are running the fixed version.

Description

CVE-2026-85297 is a vulnerability in Google Cloud Run MCP versions prior to 1.11.0 that allows bucket squatting. This flaw enables attackers to intercept and access proprietary source code, execute arbitrary code, and exfiltrate data. The issue is resolved in version 1.11.0 and later.

References

Community reviews

Loading reviews…