Skip to main content
VulnerabilityPublished

CVE-2026-85742: freescout · Cross-site Scripting

Affects freescoutSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 1.8.230 soon.

Data as of 6 Nov 2026, 17:39 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.5
Patch
Available – fixed in 1.8.230
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade freescout and freescout-help-desk/freescout to 1.8.230.

Affected software

ProductAffectedFixed in
freescout-help-deskfreescoutAffected
  • <1.8.230
Fixed in
  • 1.8.230
GitHubfreescout-help-desk/freescoutpkg:github/freescout-help-desk/freescoutOther threatsAffected
  • <1.8.230
Fixed in
  • 1.8.230

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade FreeScout to version 1.8.230 or later, where this vulnerability is fixed. No other mitigation or workaround is indicated by the vendor advisory. Applying the official fix fully addresses the issue.

Description

CVE-2026-85742 is a high-severity cross-site scripting (XSS) vulnerability in FreeScout versions prior to 1.8.230. It allows a pre-authenticated attacker to inject HTML into a failed-login email value, which is then processed and stored in a way that can lead to execution of attacker-controlled JavaScript when an administrator views specific job details. This issue requires several conditions including monitoring of user activity logs, a failed alert email job, queue failure storage, and the administrator opening a specific endpoint as a top-level page. The vulnerability is fixed in FreeScout version 1.8.230.

References

Community reviews

Loading reviews…