Skip to main content
VulnerabilityPublished Updated

CVE-2026-85787: AWS postgres-mcp-server · Incomplete List of Disallowed Inputs

Affects AWS postgres-mcp-serverSource CVE Database V5

0

Not known to be exploited · CVSS 7.1 High : upgrade to 1.1.7 soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-09-08.

Patch
Available – fixed in 1.1.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade AWS postgres-mcp-server to 1.1.7.

Affected software

ProductAffectedFixed in
Amazonpostgres-mcp-serverAffected
  • <1.1.7
Fixed in
  • 1.1.7

AI-suggested

Users should upgrade to version 1.1.7 or later of the postgres-mcp-server to remediate this vulnerability. Since this is a cloud service managed by Amazon, the vendor typically handles remediation server-side; users should consult the AWS security bulletin for confirmation and further guidance.

Description

CVE-2026-85787 is a high-severity vulnerability in Amazon's awslabs postgres-mcp-server before version 1.1.7. It involves an incomplete list of disallowed inputs in the SQL validation component, which may allow an unauthenticated attacker to modify data beyond intended read-only permissions by injecting crafted SQL when an authenticated user interacts with the server. The issue is fixed in version 1.1.7.

Reports on CVE-2026-85787

References

Community reviews

Loading reviews…