Skip to main content
VulnerabilityPublished Updated

CVE-2026-86047: MariaDB server · SQL Injection

Affects MariaDB serverSource CVE Database V5

0

Not known to be exploited · CVSS 7.7 High · fixed in 13.0.2 : patch MariaDB server soon.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 13.0.2, 12.3.3, 11.8.9 +3
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:N/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
MariaDBserverAffected
  • >=13.0.1 <13.0.2
Fixed in
  • 13.0.2
MariaDBserverAffected
  • >=12.3.1 <12.3.3
Fixed in
  • 12.3.3
MariaDBserverAffected
  • >=11.8.1 <11.8.9
Fixed in
  • 11.8.9
MariaDBserverAffected
  • >=11.4.1 <11.4.13
Fixed in
  • 11.4.13
MariaDBserverAffected
  • >=10.11.1 <10.11.19
Fixed in
  • 10.11.19
MariaDBserverAffected
  • >=10.6.1 <10.6.28
Fixed in
  • 10.6.28

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and has been released in MariaDB server versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2. Users should upgrade to these or later versions to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

MariaDB server versions from 10.6.1 up to but not including 10.6.28, 10.11.1 up to 10.11.19, 11.4.1 up to 11.4.13, 11.8.1 up to 11.8.9, 12.3.1 up to 12.3.3, and 13.0.1 up to 13.0.2 are affected by an SQL injection vulnerability. The issue arises because SHOW CREATE SERVER, SHOW CREATE USER, and mariadb-dump commands do not consistently quote identifiers and values when serializing SQL, allowing a low-privileged attacker to inject SQL commands via crafted object identifiers or values. This vulnerability is fixed in the stated versions 10.6.28, 10.11.19, 11.4.13, 11.8.9, 12.3.3, and 13.0.2.

References

Community reviews

Loading reviews…