CVE-2026-86062: HKUDS LightRAG · Cross-site Scripting
Affects HKUDS LightRAGSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 1.5.5 when convenient.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.5.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade LightRAG and hkuds/LightRAG to 1.5.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| HKUDSLightRAG | Affected
| Fixed in
|
GitHubhkuds/LightRAGpkg:github/hkuds/LightRAGOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to LightRAG version 1.5.5 or later, where this vulnerability is fixed. No additional mitigation is required once the upgrade is applied.
Description
CVE-2026-86062 is a cross-site scripting (XSS) vulnerability in HKUDS LightRAG versions prior to 1.5.5. The vulnerability arises because the application renders user-supplied content with react-markdown and rehypeRaw without sanitizing HTML, allowing attackers to inject malicious scripts. This can lead to execution of attacker-controlled JavaScript in the context of the LightRAG WebUI, potentially exposing API tokens stored in localStorage and enabling unauthorized API actions. The issue is fixed in version 1.5.5.
References
- github.com/HKUDS/LightRAG/security/advisories/GHSA-xpjq-3w4w-w5wr (opens in a new tab)
- github.com/HKUDS/LightRAG/pull/3437 (opens in a new tab)
- github.com/HKUDS/LightRAG/commit/8bf032a5200f293b482dd945d436e25cd08bd953 (opens in a new tab)
- github.com/HKUDS/LightRAG/releases/tag/v1.5.5 (opens in a new tab)