CVE-2026-86688: team-alembic ash_authentication · Session Fixation
Affects team-alembic ash_authenticationSource CVE Database V5
Not known to be exploited · CVSS 7.4 High : upgrade to 5.0.0-rc.14 or 4.15.0 soon.
Data as of 1 Nov 2026, 11:03 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.0.0-rc.14, 4.15.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 17 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade team-alembic ash_authentication to 5.0.0-rc.14 or 4.15.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| team-alembicash_authentication | Affected
| Fixed in
|
| team-alembicash_authentication | Affected
| Fixed in
|
| team-alembicash_authentication | Affected
| Fixed in– |
Hexash_authenticationpkg:hex/ash_authenticationOther threats | Affected
| Fixed in
|
CPE configurations (1)
cpe:2.3:a:team-alembic:ash_authentication:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, users should consider implementing manual session renewal upon authentication to mitigate session fixation risks. Avoid relying on the affected versions without additional session management controls.
Description
CVE-2026-86688 is a session fixation vulnerability in the team-alembic ash_authentication library. The flaw allows an attacker who can plant a session identifier in a victim's browser to maintain an authenticated session after the victim logs in. This occurs because the library writes the authenticated subject into the existing session without renewing the session identifier, allowing the original identifier to persist through login and logout cycles. This affects versions from 0.2.0 up to but not including 4.15.0, and from 5.0.0-rc.0 up to but not including 5.0.0-rc.14.
References
- github.com/team-alembic/ash_authentication/security/advisories/GHSA-v577-944g-7h3x (opens in a new tab)
- cna.erlef.org/cves/CVE-2026-86688.html (opens in a new tab)
- osv.dev/vulnerability/EEF-CVE-2026-86688 (opens in a new tab)
- github.com/team-alembic/ash_authentication/commit/a939dde9b917c072cdf10c4b0913a9886a4b0231 (opens in a new tab)
- github.com/team-alembic/ash_authentication/commit/872db454405ecad4fcdabd9ff3d8755d1d6a69ae (opens in a new tab)
- github.com/team-alembic/ash_authentication/commit/3e1d452cbf1564e87f5f97be882b66fe25af7cfa (opens in a new tab)