Skip to main content
VulnerabilityPublished Updated

CVE-2026-86831: aws-network-policy-agent · Improper Validation of Unsafe Equivalence in Input

Affects aws-network-policy-agentSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 1.4.0 soon.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.4.0, 1.22.4
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade aws-network-policy-agent and aws/aws-network-policy-agent to 1.4.0; amazon-vpc-cni-k8s and aws/amazon-vpc-cni-k8s to 1.22.4.

Affected software

ProductAffectedFixed in
AWSaws-network-policy-agentAffected
  • <1.4.0
Fixed in
  • 1.4.0
AWSamazon-vpc-cni-k8sAffected
  • >=1.14.0 <1.22.4
Fixed in
  • 1.22.4
GitHubaws/aws-network-policy-agentpkg:github/aws/aws-network-policy-agentOther threatsAffected
  • <1.4.0
Fixed in
  • 1.4.0
GitHubaws/amazon-vpc-cni-k8spkg:github/aws/amazon-vpc-cni-k8sOther threatsAffected
  • >=1.14.0 <1.22.4
Fixed in
  • 1.22.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Improper validation of pod identifier uniqueness in aws-network-policy-agent in Amazon EKS Network Policy Agent before v1.4.0 might allow an authenticated remote user to bypass NetworkPolicy enforcement on co-located pods in other namespaces via crafted pod and namespace names that produce pod identifier collisions. To remediate this issue, users should upgrade to Amazon EKS Network Policy Agent 1.4.0 or later and Amazon VPC CNI Managed Add-on v1.22.4 or later (which includes Network Policy Agent v1.4.0).

References

Community reviews

Loading reviews…