CVE-2026-87718: Apache Wicket · Protection Mechanism Failure
Affects Apache WicketSource CVE Database V5
Not known to be exploited · CVSS 2.3 Low · fixed in 10.12.0 : update Apache Wicket when convenient.
Data as of 1 Nov 2026, 22:58 UTC
Thin evidence
One scorer or none| CNA (apache) | CVSS 4.0 | 2.3 |
|---|
- Patch
- Available – fixed in 10.12.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/AU:N/RE:LExploitation evidence
Disclosed: evidence found.
CVE published 1 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Wicketorg.apache.wicket:wicket-core | Affected
| Fixed in– |
Mavenorg.apache.wicket/wicket-corepkg:maven/org.apache.wicket/wicket-coreOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Wicket to version 10.12.0 or 9.25.0, where this issue is fixed. There is no indication of any other workaround or temporary mitigation. Since this is a framework-level issue affecting CSP header application, patching is the recommended and effective remediation.
Description
Apache Wicket versions 10.10.0, 10.11.0, and 9.24.0 have a vulnerability where Content-Security-Policy (CSP) headers are not set on pages if the render request handler is wrapped in multiple IRequestHandlerDelegate layers. This occurs because the framework only unwraps one delegate level, causing pages to be served without CSP headers despite CSP being enabled. This loss of nonce-based protection for inline scripts and styles exposes affected pages to content injection risks. Versions prior to 10.10.0 and 9.24.0 handled nested delegates correctly. Upgrading to versions 10.12.0 or 9.25.0 resolves the issue.