Skip to main content
VulnerabilityPublished

CVE-2026-8779: omec-project amf · Memory Corruption

Affects omec-project amfSource CVE Database V5

0
Compare

Public exploit available · CVSS 5.3 Medium.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
omec-projectamfAffected
  • =2.1.3-dev
Fixed in–
GitHubomec-project/amfpkg:github/omec-project/amfOther threatsAffected
  • =2.1.3-dev
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:omec-project:amf:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade the omec-project amf component to version 2.2.0 or later, which contains the official fix for this vulnerability and other related security issues. No other mitigation steps are indicated or required according to the available information.

Description

A vulnerability was determined in omec-project amf up to 2.1.3-dev. Impacted is the function NGSetupRequest of the file ngap/handler.go. Executing a manipulation of the argument InformationElement can lead to memory corruption. The attack can be launched remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 2.2.0 is recommended to address this issue. The affected component should be upgraded. The same pull request fixes multiple security issues.

References

Community reviews

Loading reviews…