Skip to main content
VulnerabilityPublished

CVE-2026-87939: Drupal Feed Block · Cross-site Scripting

Affects Drupal Feed BlockSource CVE Database V5

0

Not known to be exploited · CVSS 4.2 Medium : upgrade to 3.0.2 or 2.0.2 when convenient.

Data as of 26 Oct 2026, 14:18 UTC

CVSS 3.1 base score
4.2Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.2, 2.0.2
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Drupal Feed Block to 3.0.2 or 2.0.2.

Affected software

ProductAffectedFixed in
DrupalFeed BlockAffected
  • >=3.0.0 <3.0.2
Fixed in
  • 3.0.2
DrupalFeed BlockAffected
  • <2.0.2
Fixed in
  • 2.0.2

AI-suggested

If you cannot patch yet, users should consider disabling the Feed Block module or restricting its usage to trusted users only to reduce exposure.

Description

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Feed Block allows Stored XSS. This issue affects Feed Block versions: from 0.0.0 to 2.0.2, from 3.0.0 to 3.0.2.

References

Community reviews

Loading reviews…