CVE-2026-87942: Drupal SafeDelete · Cross-site Scripting
Affects Drupal SafeDeleteSource CVE Database V5
Not known to be exploited · CVSS 4.6 Medium : upgrade to 1.0.88 when convenient.
Data as of 26 Oct 2026, 14:00 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.0.88
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Drupal SafeDelete to 1.0.88.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DrupalSafeDelete | Affected
| Fixed in
|
AI-suggested
Since the affected versions are up to but not including 1.0.88, upgrading to SafeDelete version 1.0.88 or later (if available) is recommended once confirmed by the vendor. Users should monitor official Drupal advisories for an official fix or guidance. Until a fix is confirmed, applying input validation or output encoding workarounds may reduce risk.
Description
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal SafeDelete allows Stored XSS. This issue affects SafeDelete versions: from 0.0.0 to 1.0.88.