Skip to main content
VulnerabilityPublished

CVE-2026-87949: Drupal SAML SSO – Service Provider · Cross-site Scripting

Affects Drupal SAML SSO – Service ProviderSource CVE Database V5

0

Not known to be exploited · CVSS 3.3 Low : upgrade to 3.2.0 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
3.3Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.2.0
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Drupal SAML SSO – Service Provider to 3.2.0.

Affected software

ProductAffectedFixed in
DrupalSAML SSO - Service ProviderAffected
  • <3.2.0
Fixed in
  • 3.2.0

AI-suggested

If you cannot patch yet, consider applying input validation or output encoding workarounds if feasible.

Description

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal SAML SSO - Service Provider allows Cross-Site Scripting (XSS). This issue affects SAML SSO - Service Provider versions: from 0.0.0 to 3.2.0.

References

Community reviews

Loading reviews…