CVE-2026-88024: MongoDB Rust Driver · Improper Neutralization of Special Elements in Data Query Logic
Affects MongoDB Rust DriverSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 3.9.1 when convenient.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Limited control over the software or limited information exposure
CISA SSVC assessment, 2026-09-10.
- Patch
- Available – fixed in 3.9.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade MongoDB Rust Driver to 3.9.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MongoDBRust Driver | Affected
| Fixed in
|
AI-suggested
Upgrade the MongoDB Rust Driver to version 3.9.1 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated.
Description
CVE-2026-88024 is a vulnerability in the GridFS component of the MongoDB Rust Driver where improper neutralization of special elements in data query logic allows a structured file identifier to be interpreted as a query condition. This can enable an authenticated user who can influence the identifier to access stored file content beyond the intended target or delete all GridFS file chunks in the affected bucket, making stored content unreadable. The issue affects versions from 2.4.0 up to but not including 3.9.1. A fix is available in version 3.9.1. The vulnerability has a medium severity rating with a CVSS 4.0 score of 6.1.