CVE-2026-88033: MongoDB Java Driver · Improper Neutralization of Special Elements in Data Query Logic
Affects MongoDB Java DriverSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 5.11.1 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.11.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade Java Driver and org.mongodb/mongodb-driver to 5.11.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MongoDBJava Driver | Affected
| Fixed in
|
Mavenorg.mongodb/mongodb-driverpkg:maven/org.mongodb/mongodb-driverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restrict authenticated user permissions to limit their ability to influence file identifiers passed to the GridFS component.
Description
CVE-2026-88033 is a vulnerability in the GridFS component of the MongoDB Java Driver where improper neutralization of special elements in data query logic allows an attacker to manipulate file identifiers. An authenticated user who can influence the identifier may access unintended stored file content, cause deletion of all GridFS file chunks in a bucket, or rename files other than the intended target. This affects versions from 3.3.0 up to but not including 5.11.1. The vulnerability has a medium severity with a CVSS score of 6.1.