Skip to main content
VulnerabilityPublished Updated

CVE-2026-88647: gnutls · Improper Validation of Certificate with Host Mismatch

Affects gnutlsSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.8.13 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Affects
GnuTLS prior to 3.8.13
Patch
Available – fixed in 3.8.13
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Debian debian/gnutls package to 3.8.13.

Affected software

ProductAffectedFixed in
Debiandebian/gnutlspkg:deb/debian/gnutlsOther threatsAffected
  • <3.8.13
Fixed in
  • 3.8.13

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in GnuTLS version 3.8.13. Users should upgrade to version 3.8.13 or later to remediate this vulnerability. Since this is a client-side library, patching the affected software is the recommended mitigation.

Description

A hostname verification bypass vulnerability exists in GnuTLS version prior to 3.8.13. This flaw allows attackers to circumvent the Common Name fallback mechanism, potentially enabling eavesdropping on communications when a crafted certificate is used. The vulnerability has a medium severity rating with a CVSS score of 6.5.

References

Community reviews

Loading reviews…