CVE-2026-88795: wpShopGermany IT-RECHT KANZLEI (WordPress plugin) · Code Injection
Affects wpShopGermany IT-RECHT KANZLEI (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 9.0 Critical : upgrade to 2.4 as a priority.
Data as of 31 Oct 2026, 08:20 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 17 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade wpShopGermany IT-RECHT KANZLEI (WordPress plugin) to 2.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| wpShopGermany IT-RECHT KANZLEI | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict access to the plugin's API endpoints and monitor for suspicious activity related to token usage.
Description
The wpShopGermany IT-RECHT KANZLEI WordPress plugin before 2.4 does not generate its API authentication token securely, deriving it from data the requester controls and creating it as a side effect of the check that is supposed to validate it, allowing unauthenticated attackers to predict the token and use the access it grants to write arbitrary files, leading to remote code execution.