Skip to main content
VulnerabilityPublished

CVE-2026-88806: x.org libX11 · Heap-based Buffer Overflow

Affects x.org libX11Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 1.8.14 soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.8.14
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade libX11 and x.org/libx11 to 1.8.14.

Affected software

ProductAffectedFixed in
x.orglibX11Affected
  • <1.8.14
Fixed in
  • 1.8.14
X.orgx.org/libx11pkg:deb/x.org/libx11Other threatsAffected
  • <1.8.14
Fixed in
  • 1.8.14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in libX11 version 1.8.14. Users and administrators should upgrade to version 1.8.14 or later to remediate this vulnerability. No vendor advisory content was provided, so check the official x.org or libX11 project resources for the patch and further guidance.

Description

CVE-2026-88806 is a heap-based buffer overflow vulnerability in libX11 versions before 1.8.14. It occurs during the handling of the XkbGetMap request, where the key_sym_map can be overflowed by a malicious X server. This vulnerability has a high severity with a CVSS score of 7.5. It requires user interaction and has a high impact on confidentiality, integrity, and availability.

References

Community reviews

Loading reviews…