Skip to main content
VulnerabilityPublished

CVE-2026-88807: X.org libXrender · Heap-based Buffer Overflow

Affects X.org libXrenderSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.9 High : upgrade to 0.9.13 soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 4.0 base score
8.9High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.9.13
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade libXrender and the Debian debian/libxrender package to 0.9.13.

Affected software

ProductAffectedFixed in
X.orglibXrenderAffected
  • <0.9.13
Fixed in
  • 0.9.13
Debiandebian/libxrenderpkg:deb/debian/libxrenderOther threatsAffected
  • <0.9.13
Fixed in
  • 0.9.13

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade libXrender to version 0.9.13 or later, where this heap overflow vulnerability is fixed. Since this is a client-side library vulnerability, applying the official patch is the recommended remediation. No vendor advisory content was provided to indicate alternative mitigations or that no action is required.

Description

CVE-2026-88807 is a heap-based buffer overflow vulnerability in the libXrender library used by X.org. The flaw exists in the RenderQueryPictFormats function in libXrender versions before 0.9.13. A malicious X server could exploit this vulnerability to inject code into connected X clients. The vulnerability has a high severity score of 8.9 (CVSS 4.0) and requires user interaction with a high attack complexity. No known exploits are reported in the wild. A fix is implied to exist in version 0.9.13 and later.

References

Community reviews

Loading reviews…