Skip to main content
VulnerabilityPublished

CVE-2026-88809: SUSE Rancher · Server-Side Request Forgery

Affects SUSE RancherSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.6 High · fixed in 2.15.3 : patch SUSE Rancher soon.

Data as of 2 Nov 2026, 18:58 UTC

CVSS 3.1 base score
7.6High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (suse)CVSS 3.17.6
Patch
Available – fixed in 2.15.3, 2.14.7, 2.13.11 +2
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
SUSERancherAffected
  • >=2.15.0 <2.15.3
Fixed in
  • 2.15.3
SUSERancherAffected
  • >=2.14.0 <2.14.7
Fixed in
  • 2.14.7
SUSERancherAffected
  • >=2.13.0 <2.13.11
Fixed in
  • 2.13.11
SUSERancherAffected
  • >=2.12.0 <2.12.15
Fixed in
  • 2.12.15
SUSERancherAffected
  • >=2.11.0 <2.11.19
Fixed in
  • 2.11.19
GitHubRancherpkg:github/RancherOther threatsAffected
  • >=2.15.0 <2.15.3
  • >=2.14.0 <2.14.7
  • >=2.13.0 <2.13.11
  • >=2.12.0 <2.12.15
  • >=2.11.0 <2.11.19
Fixed in
  • 2.15.3
  • 2.14.7
  • 2.13.11
  • 2.12.15
  • 2.11.19

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixed versions are available: 2.11.19, 2.12.15, 2.13.11, 2.14.7, and 2.15.3. Users should upgrade to these or later versions to remediate the vulnerability. No additional mitigation actions are specified or required beyond applying the official patches.

Description

A security vulnerability exists in the SUSE Rancher Manager meta proxy endpoint (/meta/proxy). This endpoint is intended to forward requests only to  destinations that appear on a configured allowlist. The allowlist decision was evaluated in a  place where it could not stop a request from being forwarded, so a rejected destination was logged but the request was still handed to the proxy's transport. This affects SUSE Rancher 2.15.0 up to 2.15.3, 2.14.0 up to 2.14.7, 2.13.0 up to 2.13.11, 2.12.0 up to 2.12.15, 2.11.0 up to 2.11.19 and potentially older EOL versions.

References

Community reviews

Loading reviews…