Skip to main content
VulnerabilityPublished

CVE-2026-88920: Apache WSS4J · SAML Sender-Vouches Authentication Bypass

Affects Apache WSS4JSource CVE Database V5

0

Not known to be exploited · CVSS 9.8 Critical · fixed in 4.0.2 : patch Apache WSS4J as a priority.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers can reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2026-09-30.

Patch
Available – fixed in 4.0.2, 3.0.6, 2.4.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Apache to 4.0.2, 3.0.6 or 2.4.4.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache WSS4JAffected
  • >=4.0.0 <4.0.2
Fixed in
  • 4.0.2
Apache Software FoundationApache WSS4JAffected
  • >=3.0.0 <3.0.6
Fixed in
  • 3.0.6
Apache Software FoundationApache WSS4JAffected
  • <2.4.4
Fixed in
  • 2.4.4
MavenApache Software Foundation/org.apache.wss4j:wss4j-ws-security-dompkg:maven/Apache Software Foundation/org.apache.wss4j:wss4j-ws-security-domOther threatsAffected
  • >=4.0.0 <4.0.2
  • >=3.0.0 <3.0.6
  • <2.4.4
Fixed in
  • 4.0.2
  • 3.0.6
  • 2.4.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache WSS4J to versions 4.0.2, 3.0.6, or 2.4.4 to remediate this vulnerability. No other mitigation is indicated by the vendor advisory.

Description

CVE-2026-88920 is a critical authentication bypass vulnerability in Apache WSS4J affecting the DOM security processor. It allows unauthenticated remote attackers to forge authenticated SOAP messages by using a crafted unsigned SAML sender-vouches assertion with an attacker-controlled key. This flaw enables attackers to impersonate legitimate users or services. Fixed versions are 4.0.2, 3.0.6, and 2.4.4.

References

Community reviews

Loading reviews…