Skip to main content
VulnerabilityPublished

CVE-2026-88983: kubeflow pipelines · Confused Deputy

Affects kubeflow pipelinesSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.0 Medium : upgrade to 2.17.0 when convenient.

Data as of 5 Nov 2026, 22:21 UTC

CVSS 3.1 base score
5.0Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.15.0
Patch
Available – fixed in 2.17.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade kubeflow pipelines to 2.17.0.

Affected software

ProductAffectedFixed in
kubeflowpipelinesAffected
  • <2.17.0
Fixed in
  • 2.17.0

AI-suggested

Upgrade Kubeflow Pipelines to version 2.17.0 or later, where this vulnerability is fixed. No other mitigation steps are indicated by the vendor advisory.

Description

A confused deputy vulnerability (CWE-441) exists in Kubeflow Pipelines prior to version 2.17.0. The API server's pipeline and pipeline-version creation endpoints fetch a user-supplied pipelineURL without restricting the destination, allowing an authenticated user with creation permissions to make requests from the API server to internal services and observe limited status codes. This can lead to information disclosure through a status-code oracle. The issue is fixed in version 2.17.0.

References

Community reviews

Loading reviews…