CVE-2026-89005: WPeMatico RSS Feed Fetcher (WordPress plugin) · Cross-Site Scripting (XSS)
Affects WPeMatico RSS Feed Fetcher (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.8 Medium : upgrade to 2.8.26 when convenient.
Data as of 7 Nov 2026, 23:24 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.8.26
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 24 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.
What to do
Upgrade WPeMatico RSS Feed Fetcher (WordPress plugin) to 2.8.26.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| WPeMatico RSS Feed Fetcher | Affected
| Fixed in
|
AI-suggested
Upgrade the WPeMatico RSS Feed Fetcher plugin to version 2.8.26 or later where this vulnerability is fixed. Since the plugin version 2.8.26 addresses this issue, applying this official fix is the recommended remediation. No other mitigations are specified.
Description
The WPeMatico RSS Feed Fetcher WordPress plugin before 2.8.26 does not sanitise and escape one of its campaign configuration fields when a certain feature is enabled, which allows users with the Contributor role and above to perform Stored Cross-Site Scripting attacks that execute in the session of any higher-privileged user who later views the campaign.