Skip to main content
VulnerabilityPublished

CVE-2026-89173: Kingdom Communication Associated EH3040 · Response Discrepancy Information Exposure

Affects Kingdom Communication Associated EH3040Source CVE Database V5

0

Not known to be exploited · CVSS 6.9 Medium : upgrade to 2.5.0A when convenient.

Data as of 27 Oct 2026, 05:11 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.5.0A, 2.7.0A, 2.8.0A
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade EH3040 and EH4200 to 2.5.0A; EH1000B to 2.7.0A; EH2070 to 2.8.0A.

Affected software

ProductAffectedFixed in
Kingdom Communication AssociatedEH3040Affected
  • <2.5.0A
Fixed in
  • 2.5.0A
Kingdom Communication AssociatedEH4200Affected
  • <2.5.0A
Fixed in
  • 2.5.0A
Kingdom Communication AssociatedEH1000BAffected
  • <2.7.0A
Fixed in
  • 2.7.0A
Kingdom Communication AssociatedEH2070Affected
  • <2.8.0A
Fixed in
  • 2.8.0A

AI-suggested

If you cannot patch yet, limit exposure of the device to untrusted networks and consider network-level access controls to reduce attack surface.

Description

Smart Video Intercom System developed by Kingdom Communication Associated has a Sensitive Data Exposure vulnerability. Unauthenticated remote attackers can enumerate valid user accounts by exploiting differences in system responses.

References

Community reviews

Loading reviews…