Skip to main content
VulnerabilityPublished

CVE-2026-89259: gohugoio hugo · Execution with Unnecessary Privileges

Affects gohugoio hugoSource CVE Database V5

0

Not known to be exploited · CVSS 9.3 Critical : upgrade to 0.165.0 as a priority.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.165.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade hugo and gohugoio/hugo to 0.165.0.

Affected software

ProductAffectedFixed in
gohugoiohugoAffected
  • <0.165.0
Fixed in
  • 0.165.0
GitHubgohugoio/hugopkg:github/gohugoio/hugoOther threatsAffected
  • <0.165.0
Fixed in
  • 0.165.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Hugo version 0.165.0, which removes TailwindCSS from the default security.exec.allow list, restoring proper execution restrictions. Users should upgrade to version 0.165.0 or later. As a workaround, users can define a restrictive security.exec.allow list in the hugo.toml configuration file to limit Node tool permissions and prevent the bypass. Users not using TailwindCSS or only building trusted sites are not affected and may not require immediate action.

Description

CVE-2026-89259 is a critical vulnerability in the Hugo static site generator affecting versions before 0.165.0. The issue arises because TailwindCSS, included in the default security.exec.allow list, requires highly permissive Node.js execution flags that can bypass intended security restrictions. This allows Node tools invoked during a Hugo build to read and write files outside the project directory. The vulnerability was fixed in version 0.165.0 by removing TailwindCSS from the default allow list. Users not using TailwindCSS or only building trusted sites are not affected. A workaround is to define a restrictive security.exec.allow list in the hugo.toml configuration file.

References

Community reviews

Loading reviews…