Skip to main content
VulnerabilityPublished Updated

CVE-2026-8933: Ubuntu 26.04 LTS snapd · Execution with Unnecessary Privileges

Affects Ubuntu 26.04 LTS snapdSource CVE Database V5

0

Not known to be exploited · CVSS 7.8 High : upgrade Ubuntu 26.04 LTS snapd to 2.76.1 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.76.1
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade snapd to 2.76.1.

Affected software

ProductAffectedFixed in
snapdAffected
  • >=2.75.0 <2.76.1
Fixed in
  • 2.76.1
GitHubsnapdpkg:github/snapdOther threatsAffected
  • >=2.75.0 <2.76.1
Fixed in
  • 2.76.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Avoid running snap-confine with set-capabilities configuration if possible, or restrict local user access to affected systems as a precaution.

Description

CVE-2026-8933 is a local privilege escalation vulnerability in snap-confine, a core component used by Canonical snapd to create secure execution environments for snap applications. The flaw affects versions of snap-confine configured with set-capabilities rather than set-uid-root. An unprivileged local attacker can exploit this vulnerability to bypass security restrictions and execute arbitrary code with full root privileges. The vulnerability has a high severity score of 7.8 and impacts version 2.75.0.

References

Community reviews

Loading reviews…