Skip to main content
VulnerabilityPublished

CVE-2026-8981: Custom Block Builder (WordPress plugin) · Cross-Site Scripting (XSS)

Affects Custom Block Builder (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 3.5 Low : upgrade to 4.3.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
3.5Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.3.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Custom Block Builder (WordPress plugin) to 4.3.0.

Affected software

ProductAffectedFixed in
Custom Block BuilderAffected
  • <4.3.0
Fixed in
  • 4.3.0

AI-suggested

If you cannot patch yet, administrators should be cautious when managing block template code fields and consider restricting administrative access. Monitoring for plugin updates and applying them promptly once available is recommended.

Description

The Custom Block Builder WordPress plugin before version 4.3.0 contains a cross-site scripting (XSS) vulnerability. This occurs because the plugin does not consistently verify the unfiltered_html capability when writing to block template code fields. As a result, administrators on multisite installations or single-site installs with DISALLOW_UNFILTERED_HTML defined can inject arbitrary JavaScript. This malicious script executes for any visitor viewing pages with the affected block. The vulnerability has a low severity score and no known exploits in the wild.

References

Community reviews

Loading reviews…