Skip to main content
VulnerabilityPublished Updated

CVE-2026-90534: FlowiseAI Flowise · Insecure Direct Object Reference

Affects FlowiseAI FlowiseSource CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 3.1.4 when convenient.

Data as of 27 Oct 2026, 17:11 UTC

CVSS 4.0 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.1.4
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:L/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Flowise and flowiseai/Flowise to 3.1.4.

Affected software

ProductAffectedFixed in
FlowiseAIFlowiseAffected
  • <3.1.4
Fixed in
  • 3.1.4
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threatsAffected
  • <3.1.4
Fixed in
  • 3.1.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Flowise version 3.1.4. Users should upgrade to version 3.1.4 or later to remediate this vulnerability. Since this is a cloud service, the vendor manages remediation for hosted instances; users should verify with the vendor that their service is updated. No additional mitigation steps are indicated by the vendor advisory.

Description

Flowise is a low-code platform for building LLM applications. In versions up to and including 3.1.3, the POST /api/v1/node-load-method/:name endpoint is mounted without any route-level permission check and invokes component loadMethods with an attacker-controlled nodeName, loadMethod, inputs, and credential value. The selected credential is resolved by raw Credential.id via getCredentialData() and decrypted without verifying Credential.workspaceId against the caller's active or shared workspace, unlike other credential read paths which are workspace-scoped. As a result, an authenticated low-privilege user (or workspace API key) in one workspace can supply a credential ID owned by another workspace and cause Flowise to act as a confused deputy, performing third-party provider calls with the victim workspace's credential and returning provider metadata to the attacker. Statically identified affected load methods include Google Drive listFiles, Google Sheets listSpreadsheets, and AWS DynamoDB KV Storage listTables. The raw credential secret itself is not returned to the attacker. This issue is fixed in version 3.1.4.

References

Community reviews

Loading reviews…