Skip to main content
VulnerabilityPublished Updated

CVE-2026-90580: FlowiseAI Flowise · Server-Side Request Forgery

Affects FlowiseAI FlowiseSource CVE Database V5

0

Public exploit available · CVSS 5.3 Medium · end of life, no fix coming : replace or isolate FlowiseAI Flowise; no fix will be released.

Data as of 27 Oct 2026, 17:11 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
None coming – the product is end of life
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

No fix will be released: FlowiseAI Flowise is end of life. Replace it, or isolate it from untrusted networks until you can.

Affected software

ProductAffectedFixed in
FlowiseAIFlowiseAffected
  • =3.0.0
  • =3.0.1
  • =3.0.2
Fixed in–
npmflowiseai/flowisepkg:npm/flowiseai/flowiseOther threatsAffected
  • =3.0.0
  • =3.0.1
  • =3.0.2
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:flowiseai:flowise:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade FlowiseAI Flowise to version 3.1.3 or later, which contains the official fix for this SSRF vulnerability. Since the affected versions are no longer supported, upgrading to a supported version is strongly recommended to mitigate this issue.

Description

A vulnerability was found in FlowiseAI Flowise up to 3.0.2. This vulnerability affects the function axios.post of the file packages/server/src/controllers/evaluations/index.ts of the component Evaluations Endpoint. The manipulation of the argument Host/X-Forwarded-Proto results in server-side request forgery. The attack may be launched remotely. The exploit has been made public and could be used. Upgrading to version 3.1.3 is able to resolve this issue. The patch is identified as 700137738bcaebefd4709021f6d6b0abcd7df0ac. It is recommended to upgrade the affected component. This vulnerability only affects products that are no longer supported by the maintainer.

References

Community reviews

Loading reviews…