Skip to main content
VulnerabilityPublished Updated

CVE-2026-90683: GPAC · Reachable Assertion

Affects GPACSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Public exploit available · CVSS 4.8 Medium : upgrade to 16.23 as a priority.

Data as of 29 Oct 2026, 07:15 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 16.23
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade gpac/gpac to 16.23.

Affected software

ProductAffectedFixed in
GPACAffected
  • =f1219cde
Fixed in–
GitHubgpac/gpacpkg:github/gpac/gpacOther threatsAffected
  • <16.23
Fixed in
  • 16.23

CPE configurations (1)

  • cpe:2.3:a:gpac:gpac:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade GPAC to version 16.23 or later, which contains the official patch addressing this vulnerability. No other mitigation is indicated.

Description

A vulnerability was detected in GPAC up to f1219cde. Affected is the function gf_node_unregister of the file scenegraph/base_scenegraph.c of the component MP4Box. Performing a manipulation results in reachable assertion. Attacking locally is a requirement. The exploit is now public and may be used. Upgrading to version abi-16.23 is able to address this issue. The patch is named 49dee5cad329cfed310c1682703df7daa47df31a. It is advisable to upgrade the affected component. This is not a duplicate of CVE-2021-46237 or CVE-2021-46234.

References

Community reviews

Loading reviews…