CVE-2026-91011: EWWW Image Optimizer (WordPress plugin) · Cross-Site Scripting (XSS)
Affects EWWW Image Optimizer (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.8 Medium : upgrade to 8.7.7 when convenient.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.7.7
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 17 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade EWWW Image Optimizer (WordPress plugin) to 8.7.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| EWWW Image Optimizer | Affected
| Fixed in
|
AI-suggested
A fix is available in EWWW Image Optimizer version 8.7.7. Users should upgrade to version 8.7.7 or later to remediate this vulnerability. No other mitigation guidance is provided by the vendor advisory.
Description
The EWWW Image Optimizer WordPress plugin before 8.7.7 does not properly escape image attribute values when it rewrites page output, allowing authenticated users with author-level access and above to inject arbitrary JavaScript that is stored in published content and executes in the browser of any user who later views the affected page.