CVE-2026-91086: GPAC · Heap-based Buffer Overflow
Affects GPACSource CVE Database V5
Public exploit available · CVSS 5.3 Medium.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 15 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| GPAC | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:gpac:gpac:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available. Users should upgrade GPAC to version abi-16.23 or later, which includes the patch afca1f1181668d85941d51ed1adf647807d5d975 that addresses this heap-based buffer overflow vulnerability. Applying this update is the recommended mitigation.
Description
A security vulnerability has been detected in GPAC up to f1219cde. Affected by this issue is the function mpgviddmx_process of the file filters/reframe_mpgvid.c of the component MPEG Video Reframer. Such manipulation leads to heap-based buffer overflow. The attack can be executed remotely. The exploit has been disclosed publicly and may be used. Upgrading to version abi-16.23 can resolve this issue. The name of the patch is afca1f1181668d85941d51ed1adf647807d5d975. Upgrading the affected component is recommended.
References
- vuldb.com/vuln/403647 (opens in a new tab)
- vuldb.com/vuln/403647/cti (opens in a new tab)
- vuldb.com/cve/CVE-2026-91086 (opens in a new tab)
- vuldb.com/submit/919755 (opens in a new tab)
- github.com/gpac/gpac/issues/3806 (opens in a new tab)
- github.com/user-attachments/files/30399291/poc_10_add.zip (opens in a new tab)
- github.com/gpac/gpac/commit/afca1f1181668d85941d51ed1adf647807d5d975 (opens in a new tab)
- github.com/gpac/gpac/releases/tag/abi-16.23 (opens in a new tab)
- github.com/gpac/gpac/ (opens in a new tab)