CVE-2026-91087: GPAC · Use After Free
Affects GPACSource CVE Database V5
Public exploit available · CVSS 6.9 Medium : upgrade to 16.24 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 16.24
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 15 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade gpac/gpac to 16.24.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| GPAC | Affected
| Fixed in– |
GitHubgpac/gpacpkg:github/gpac/gpacOther threats | Affected
| Fixed in
|
CPE configurations (1)
cpe:2.3:a:gpac:gpac:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade GPAC to version abi-16.24 or later, which contains the official fix for this vulnerability. Applying this update fully mitigates the risk. No additional mitigations are specified or required.
Description
A flaw has been found in GPAC up to f1219cde. This vulnerability affects the function gf_mo_get_od_id of the file compositor/media_object.c of the component Compositor. Executing a manipulation can lead to use after free. The attack may be performed from remote. The exploit has been published and may be used. Upgrading to version abi-16.24 is able to resolve this issue. This patch is called e34f4ba349d55cd1849f0bcf4cf46552732e2db7. Upgrading the affected component is advised.
References
- vuldb.com/vuln/403649 (opens in a new tab)
- vuldb.com/vuln/403649/cti (opens in a new tab)
- vuldb.com/cve/CVE-2026-91087 (opens in a new tab)
- vuldb.com/submit/919756 (opens in a new tab)
- github.com/gpac/gpac/issues/3807 (opens in a new tab)
- github.com/user-attachments/files/30399593/poc_12_info.zip (opens in a new tab)
- github.com/gpac/gpac/commit/e34f4ba349d55cd1849f0bcf4cf46552732e2db7 (opens in a new tab)
- github.com/gpac/gpac/releases/tag/abi-16.24 (opens in a new tab)
- github.com/gpac/gpac/ (opens in a new tab)