CVE-2026-91091: GPAC · Memory Corruption
Affects GPACSource CVE Database V5
Public exploit available · CVSS 5.3 Medium : upgrade to 16.23 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 16.23
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 15 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade gpac/gpac to 16.23.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| GPAC | Affected
| Fixed in– |
GitHubgpac/gpacpkg:github/gpac/gpacOther threats | Affected
| Fixed in
|
CPE configurations (1)
cpe:2.3:a:gpac:gpac:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade GPAC to version abi-16.23 or later, which contains the official fix for this vulnerability. Applying this upgrade fully mitigates the issue.
Description
A vulnerability was identified in GPAC up to f1219cde. The impacted element is the function gf_node_list_insert_child of the file scenegraph/base_scenegraph.c of the component Node Insertion. Such manipulation leads to memory corruption. The attack can be launched remotely. The exploit is publicly available and might be used. Upgrading to version abi-16.23 is sufficient to resolve this issue. The name of the patch is 49dee5cad329cfed310c1682703df7daa47df31a. It is suggested to upgrade the affected component.
References
- vuldb.com/vuln/403653 (opens in a new tab)
- vuldb.com/vuln/403653/cti (opens in a new tab)
- vuldb.com/cve/CVE-2026-91091 (opens in a new tab)
- vuldb.com/submit/919761 (opens in a new tab)
- github.com/gpac/gpac/issues/3811 (opens in a new tab)
- github.com/user-attachments/files/30400179/poc_18_nstatx.zip (opens in a new tab)
- github.com/gpac/gpac/commit/49dee5cad329cfed310c1682703df7daa47df31a (opens in a new tab)
- github.com/gpac/gpac/releases/tag/abi-16.23 (opens in a new tab)
- github.com/gpac/gpac/ (opens in a new tab)