Skip to main content
VulnerabilityPublished Updated

CVE-2026-91102: HP Linux Imaging and Printing Software (HPLIP) · OS Command Injection

Affects HP Linux Imaging and Printing Software (HPLIP)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.4 High : upgrade to 3.26.6 soon.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 4.0 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.26.6
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade hp/hplip to 3.26.6.

Affected software

ProductAffectedFixed in
HP Inc.HP Linux Imaging and Printing Software (HPLIP)Affected
  • <3.26.6
Fixed in–
Hphp/hplippkg:deb/hp/hplipOther threatsAffected
  • <3.26.6
Fixed in
  • 3.26.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

HP has remediated this vulnerability in HPLIP version 3.26.6. Users should upgrade to version 3.26.6 or later to mitigate the risk. No additional mitigation steps are indicated by the vendor advisory.

Description

HP has identified and remediated multiple externally reported vulnerabilities within HPLIP. The findings affect several software components that could potentially enable remote code execution, privilege escalation, denial of service, information disclosure, or unauthorized file modification under certain conditions.

References

Community reviews

Loading reviews…