CVE-2026-91130: home-assistant core · Basic XSS
Affects home-assistant coreSource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 2026.7.0 as a priority.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2026.7.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 22 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade core and home-assistant/core to 2026.7.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| home-assistantcore | Affected
| Fixed in
|
GitHubhome-assistant/corepkg:github/home-assistant/coreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in Home Assistant core version 2026.7.0. Users should upgrade to version 2026.7.0 or later to remediate this issue. No additional mitigation steps are indicated by the vendor advisory.
Description
CVE-2026-91130 is a critical cross-site scripting (XSS) vulnerability in Home Assistant core prior to version 2026.7.0. The issue arises from improper escaping of entity names interpolated into ECharts tooltip HTML in the Statistics Graph card, allowing script execution when a viewer hovers over a data point. This affects Mean, State, Sum, and Change fields in the default Line chart configuration but not Bar charts. The vulnerability requires authentication or control over an integration that supplies entity names. It is fixed in version 2026.7.0.
References
- github.com/home-assistant/core/security/advisories/GHSA-wx4m-69m9-gx3m (opens in a new tab)
- github.com/home-assistant/frontend/pull/52235 (opens in a new tab)
- github.com/home-assistant/frontend/commit/b8c201b6d34414d30c622797366570185c219614 (opens in a new tab)
- github.com/home-assistant/core/releases/tag/2026.7.0 (opens in a new tab)