CVE-2026-91159: discourse · Cross-site Scripting
Affects discourseSource CVE Database V5
Not known to be exploited · CVSS 7.7 High · fixed in 2026.9.0 : patch discourse soon.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Limited control over the software or limited information exposure
CISA SSVC assessment, 2026-10-20.
- Patch
- Available – fixed in 2026.9.0, 2026.8.1, 2026.7.3 +1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade discourse to 2026.9.0, 2026.8.1, 2026.7.3 or 2026.1.9.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| discoursediscourse | Affected
| Fixed in
|
| discoursediscourse | Affected
| Fixed in
|
| discoursediscourse | Affected
| Fixed in
|
| discoursediscourse | Affected
| Fixed in
|
Description
Discourse is an open-source discussion platform. Prior to 2026.9.0, 2026.8.1, 2026.7.3, and 2026.1.9, oEmbed processing treated an entire attacker-controlled HTML fragment as trusted when the fragment contained an iframe whose source matched the configured allowlist. A user with posting permission who controlled a public webpage and its oEmbed response could combine an allowlisted iframe with unrelated sibling HTML or CSS, causing stored visual overlays or other styled content to appear in post content and enabling misleading or fraudulent user interfaces. Exploitation requires a posting account, control of the fetched webpage and oEmbed response, and an allowlisted iframe source. The issue affects content integrity but does not expose restricted data, disrupt availability, or require interaction with Discourse Content Security Policy. This issue is fixed in versions 2026.9.0, 2026.8.1, 2026.7.3, and 2026.1.9.
References
- github.com/discourse/discourse/security/advisories/GHSA-f9jx-vv33-4282 (opens in a new tab)
- github.com/discourse/discourse/commit/0953b31f5c2949d7d6ab5f6dc4c5e2f1b8bf0b22 (opens in a new tab)
- github.com/discourse/discourse/commit/3fc2bad6cdca47b00958330d1ee612aa141b039a (opens in a new tab)
- github.com/discourse/discourse/commit/dde8bc4fb6200139f5eff7e100b0f3e829d37ab3 (opens in a new tab)
- github.com/discourse/discourse/commit/ed6f83f123d1a4c6c6c7e64c8a2233e3cb6a28d7 (opens in a new tab)