CVE-2026-91941: unclecode crawl4ai · Uncontrolled Resource Consumption
Affects unclecode crawl4aiSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 0.9.3 soon.
Data as of 30 Oct 2026, 20:25 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.9.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade crawl4ai and unclecode/crawl4ai to 0.9.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| unclecodecrawl4ai | Affected
| Fixed in
|
GitHubunclecode/crawl4aipkg:github/unclecode/crawl4aiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in crawl4ai version 0.9.3. Users should upgrade to version 0.9.3 or later to remediate this vulnerability. No additional mitigation steps are indicated.
Description
Crawl4AI before 0.9.3 contains an uncontrolled resource consumption vulnerability in PDFContentScrapingStrategy that allows untrusted clients to cause denial of service. Attackers can select the PDF scraping strategy in POST requests to download large remote PDFs without size or page limits, exhausting disk, CPU, and bandwidth on shared workers.