Skip to main content
VulnerabilityPublished Updated

CVE-2026-91992: tornadoweb tornado · Information Exposure

Affects tornadoweb tornadoSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.2 High : upgrade to 6.5.7 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.5.7
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade tornadoweb tornado to 6.5.7.

Affected software

ProductAffectedFixed in
tornadowebtornadoAffected
  • <6.5.7
Fixed in
  • 6.5.7
PyPItornadopkg:pypi/tornadoOther threatsAffected
  • <6.5.7
Fixed in
  • 6.5.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Tornado version 6.5.7. Users should upgrade to version 6.5.7 or later to remediate this vulnerability. No additional mitigation steps are indicated beyond applying the official patch.

Description

Tornado versions before 6.5.7 contain a vulnerability in CurlAsyncHTTPClient where pycurl handles are reused across requests without properly clearing state. This can lead to leakage of sensitive credentials such as TLS certificates or proxy authentication data across unintended requests. The vulnerability has a medium severity with a CVSS score of 5.9. Multiple specific Tornado package versions are affected.

References

Community reviews

Loading reviews…